SMSFactor UI platform is unavailable

Minor incident Customer Portal
2026-06-12 12:46 CEST · 17 minutes

Updates

Resolved

Platform is back up. We’re really sorry for the inconvenience.

June 12, 2026 · 13:03 CEST
Issue

The UI portal my.smsfactor.com is currently unavailable. We’re working on a fix.

June 12, 2026 · 12:46 CEST

← Back