Services and websites not available due to DDOS attack

Incident Report for SMSFactor

Resolved

Hi everyone,

We're still fixing the last minor issues some users are still facing regarding yesterday's DDoS attack.

For your information, we've switched our DNS servers from Scaleway to Cloudflare to help us mitigate the attack (Scaleway couldn't deliver, Cloudflare did). This means that we had to migrate our entire zone DNS, meaning the IP behind api.smsfactor.com is no longer 51.159.21.54 but is rather an IP from Cloudflare as it now acts as a proxy. Some of you might still be impacted because of the time needed for DNS propagation. If you can and if you know you have to, we invite you to flush your DNS cache.

If you notice anything unusual, please send an email to support@smsfactor.com, we'll be more than happy to help you.

A Post-mortem will follow later today to explain in details exactly what happened and how we managed to restore the services. Again, we're really sorry this happened and for the inconvenience. Your patience and the kind words we received during the incident meant a lot.
Posted Oct 31, 2024 - 11:50 CET

Update

We are continuing to monitor for any further issues.
Posted Oct 30, 2024 - 21:14 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2024 - 21:14 CET

Update

We're still trying to restore the API and portals as they should be. We're currently working with our hosting provider to mitigate the attack. Your patience is deeply appreciated.
Posted Oct 30, 2024 - 17:39 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 30, 2024 - 14:00 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2024 - 11:49 CET

Investigating

We are currently investigating this issue.
Posted Oct 30, 2024 - 10:57 CET
This incident affected: API and Customers Portal.